For some reason Gigabyte GA-H55N-USB3 motherboard by default sets SATA to IDE mode (I believe the same is true for many other Gigabyte 5-series). But during boot it will detect SATA setting and, if in IDE, it will then prompt you to switch to AHCI for better performance.

IMAG2584

 

You should use AHCI, of course. If this is the very first OS install for the build (so the hard drives are empty), everything will be fine.

However, if your boot drive has Windows previously installed in IDE mode, and you switch SATA to AHCI, you would not be able to boot into the system. This is nothing new and many people have run into this problem. There are excellent guides on how to change SATA mode from IDE to AHCI here and here when Windows is installed in IDE mode. But things are slightly different on Gigabyte motherboards.

Gigabyte will stop you at POST before Windows can throw you an error message. Typically you are stuck somewhere during storage device enumeration:

Serial ATA AHCI Bios, Version iSRC 1.20E
Copyright (c) 2003-2008 Intel Corporation_________________________23
** This version supports only HardDisks & CDROM drives **
Please wait. This will take a few seconds.

Controller Bus#00, Device #1F, Function #02: 06 Ports, 05 Devices

If you boot into the system with SATA in IDE mode and change registry and BIOS settings as shown in the two links above, upon restart you would still be stuck at storage device enumeration. At this point you can’t even enter BIOS and switch it back to IDE, because Gigabyte would not let you before it finishes storage device enumeration, which it ain’t gonna finish. You have to clear CMOS which resets SATA mode to IDE. This can be quite annoying with a Mini-ITX board and Mini-ITX case.

Many have reported similar problems. Here are just a few examples: 1, 2, 3. They are all Gigabyte and all 5-series motherboards. X58 is particularly problematic with its massive and messy storage capabilities. X58A-UD3R has four SATA controllers for a total of 10 SATA ports, which makes debugging even more challenging.

The solution is to wipe out the drive with OS installed when the drive is in IDE mode. Link 3 above says you have to do it using “third party tool”. I am not sure what they meant by that. But you certainly don’t need to plug the drive into another machine and you don’t need anything other than a Windows installation disk/bootable thumb drive. Just clear CMOS to load BIOS defaults so that SATA switches back to IDE mode (again, you have to do it this way because entering BIOS/boot menu happens after storage device enumeration). Now the system can pass POST and let you select boot drive. Run Windows installation. Use the drive tools in the installation program to delete all partitions in the boot drive. Reboot and enter BIOS. Change SATA mode to AHCI (you must do this BEFORE installing Windows). Now go ahead and reinstall Windows.

The following is what I did to my computer that messed it up. You can decide if my solution would work for you.

  1. Tried to use Q Flash to update BIOS. Didn’t work. Load BIOS default (which quietly changed SATA to IDE mode)
  2. Reboot and entered boot menu (When in IDE mode, there is no SATA device enumeration and you can access BIOS/boot menu freely). Boot from installation flash drive and installed Windows.
  3. During the first reboot after installation, BIOS prompted a SATA mode change from IDE to AHCI and I chose yes.
  4. Got stuck at SATA device enumeration.
Advertisements